Hobbyist Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6,772 Posts
Discussion Starter #1
I have two of these little tachs and have had great luck with them. Until recently. I killed them both, not sure how but I did.

The first one gave up at the NCS race in Clover, it just quit reading and blank display, no amount of resetting would help. I figured it had had it due to some wrecks or whatever. Swapped to my spare and went on about my race.

then the next race back at LPR the second one died. It only had about 5 hours on it, I thought it was very odd.

I called the guys at Trail Tech 360-687-4530 and spoke to a guy named Garridan. I explained my situation and he told me that they were aware of the tachs doing that in some instances and offered to replace both of my tach free of charge with ones that were upgraded to supposedly fix this issue.

Not often do you get customer service like that anymore, usually it is "do you have a receipt?", "you did something wrong" or "too bad, so sad".

:thumbsup::thumbsup: Trail Tech.
 

·
Registered
Joined
·
487 Posts
I have one of those tachs. and have had great service out of it. I highly recommend them.
 

·
Registered
Joined
·
487 Posts
Scott,
You bought silver ones.... mine is orange. Maybe a color change? LOL.......... But hey, the service out of the company is outstanding. Thanks for the info.
 

·
Premium Member
Joined
·
5,385 Posts
There customer service is good. I bought one a couple years back and after receiving it I found out that it wasn't the tach for me. It only holds max rpm for 5 seconds after motor is shut off. They told me they would look in to trying to change this. I sent it back for a full refund b/c that was not described in the directions.
 

·
Premium Member
Joined
·
190 Posts
It described that feature in my instructions and online when looking at it, you can also retrieve it by the button on the bottom. Mine is mounted with velcro. Very good tach.
 
1 - 7 of 7 Posts
Top