Hobbyist Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hello everyone. I have rebuilt many small engine carbs. This one looks to be a challenge. It's off a Toro CCR200 snow thrower with a Susuki 47PS5-5 engine. Parts diagrams show it to be a float style carb. How difficult are these carbs to rebuild? I'm used to B&S or Tecumseh kits that are available for under $15. The kit for this carb is over $50. How complete are these kits? Do they include the carb to intake gasket? Anything I need to be aware of before tearing into it? Thanks in advance!
 

·
Registered
Joined
·
6,116 Posts
I don't think that they are any more difficult than any other brands of carburetors to work on. Since the parts are so expensive for them, I rarely kit them unless it's absolutely needed. I usually just clean them up, being very careful not to destroy any parts when tearing down the carburetor.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Thanks for the info. Does this carb use a conventional rubber seat or rubber tipped needle? Is the float adjustable? I can't find a whole lot of information on servicing this carb.

The problem with the snow thrower appears like fuel starvation. The unit starts up pretty well. However, the engine stall after about 15 minutes of throwing snow. It also tends to die if it idles for an extended time.

I've taken the bowl off. It was surprisingly clean inside. I sprayed carb cleaner into the carb through the fuel inlet, primer inlet and sprayed around the float as it was hanging (carb still mounted to the engine). Hopefully the cleaner didn't hurt the seat. I then gently blew out the passages as best I could. I was hoping the carb would have had a conventional bowl nut, so I could have cleaned the jet.

Any ideas??
 

·
Registered
Joined
·
6,116 Posts
Depending upon the specific carburetor used, your needle may be solid or rubber tipped. If it runs alright for 15 minutes then it may not be a carburetor problem. It could be the fuel tank vent either in the fuel cap or tank itself, causing a vacuum to build and fuel to stop flowing. Try running with the fuel cap loose and see if this corrects the problem.
 
1 - 5 of 5 Posts
Top