Hobbyist Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
Have 3.5 B&S engine if I put some gas in the carb it runs for about 30 seconds stalls out is there anything I can do other than take the carb off?

WHat seems to be the problem?

Thanks
 

·
Registered
Joined
·
750 Posts
does it run at rough idle? does it have enough compression? how is the diaphram? tank gasket? is the pickup tube unclogged or did it fall into tank? is the gas PURE gasoline not gas water mix?
 

·
Registered
Joined
·
73 Posts
what style carb is it? float or the kind mounted to the tank? if its mounted to the tank you probably need a new diaphragm and gasket and clean the carb especially the pickup tube if it has a primer make sure the gasket for it is in good shape. for a float style some times you can get away with just removing the bowl and clean out any contaminants and spray carb cleaner directly up through the main jet.depending on the level of varnish you have. if its too bad reove and give it a thorough cleaning. same thing with the diaphragm carb. and clean the tank also. :wave:
 

·
Registered
Joined
·
272 Posts
Really helps when you give the MODEL NUMBER of engine, TYPE NUMBER, and CODE NUMBER. That way we could lookup engine and know what type carb and the specs.
 

·
Registered
Joined
·
750 Posts
true, but most briggs 3/3.5hp engines use almost the same type o' carb, but yes the numbers would help to maybe see the break-apart of the diaphram.. but if its a rip off one... probably nio manufACTURER at all unless you contact the sller
 
1 - 6 of 6 Posts
Top