Hobbyist Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
433 Posts
Discussion Starter · #1 ·
A few weeks ago I bought my first LIpo Orion 2400 and had a guy at the track set up my ICE to charge it. While charging the pack puffed up and was unusable. The shop I bought it off of refunded my money no problem and I haveb ought another one. Now I am worried about charging it because the same thing might happen. Here are the settings I have now on my ICE.

Lipo 7.4V 2400 MAH
Chg Current 2.4A
Dchg Current 2.0A
Dchg Volt 2.8 V/C
Cut off Temp 90
Max Charge Capacity 90%

Now when I charged the other one the LIpo was set at 5000 MAH and the Chg current was set at 5.0. The Max charge Capacity was set at 110%. I looked at the guys chrger who set it and that was the same he was charging his at on his ICE. We all agreed the battery was the problem but I am worried about lighting this one up in my shop. I have a race with it on Sunday so I have to do something. Please tell me if these settings are ok or if I need to change them

Thanks alot.

Bob
 

·
Trying to go Fast!
Joined
·
1,245 Posts
Those settings are fine sounds like you just had a bad lipo at first and yes discharge rate shows all time on setup.
 

·
Registered
Joined
·
7,168 Posts
When you press the button to start the charge, make certain you don't change to a different batt profile. I saw I guy set his Ice for a 3200 lipo and press the button but he must have pressed it crooked as it switched to NIMH and puffed the lipo. Just a thought.
 

·
Registered
Joined
·
260 Posts
Yea I did the same thing. Caught it as I turned it on and didn't hurt anything but you have to make sure you push the button carefully. Your settings are fine.
 

·
Used to be racer......
Joined
·
4,210 Posts
That's because you have one of those single cell equalizers from MaxxGullo Motorsports. ;) :lol:
 

·
Registered
Joined
·
3,233 Posts
Sometimes When you press the button to select charge or discharge with the ice the dial can turn & give you dischsrge & change to the next battery select. This has happened to me several times. Now I always read the screen after starting it. Other than that no problems.
 

·
Registered
Joined
·
2,887 Posts
I blew out an Orion as well, didn't do anything wrong, the battery just shorted somewhere inside. Don't think the fault is with your charger, in my opinion.
 

·
Registered
Joined
·
52 Posts
Even if your not gonna use the ICE to discharge the battery, I would wet it to 3.0 discharge voltage as a precaution. I personally would not disharge to 2.8 volts.
 
1 - 13 of 13 Posts
Top