Hobbyist Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have rebuilt the carb, welbro 603. replaced all the seals, gaskets, bearings, piston ring, head gasket. Will not start. sprayed carb cleaner down the throat of the carb nothing. Put gas down spark plug hole nothing. Is it possible that a spark plug can work when grounded against the head(lots of blue spark)but not when it is installed? I don't like this engine! please help, Thanks Mike
 

·
Registered
Joined
·
2,466 Posts
check your other post..

if the spark plug sparks off the engine It will spark installed.

you can not find a simpler engine anywhere, but it can be picky if not assemble and working correctly.

even the smallest leak on the complete engine can stop it from starting/running.

check your other post.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Carb gaskets leaking

Hi, I took my Carb off and noticed gas was leaking on all three gaskets between the Carb and the engine. Not enough to drip but wet from the intake hole down to the bottom corner. I'm thinking Air Leak but I'm afraid to tighten the bolts more, might break something. Do you Guys use any kind of sealer on these? Thank You Mike
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Hi, I took my Carb off and noticed gas was leaking on all three gaskets between the Carb and the engine. Not enough to drip but wet from the intake hole down to the bottom corner. I'm thinking Air Leak but I'm afraid to tighten the bolts more, might break something. Do you Guys use any kind of sealer on these? Thank You Mike
I couldn't find my other post, so I thought I did something wrong and posted again. Sorry found it now. Thanks
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
My piston is in backwards

Arrow Should face exhaust mine faces Carb. I thought front was meaning toward carb. I feel like a Dumb arse. I was watching a rebuild video after I put the engine together not before,DANG !!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
piston to front still no start

It does nothing, JUNK! I'm going to try a new spark plug, because it acts like there is no spark. The plug I have now comes out of the engine wet, sparks like crazy when not installed. If this don't work I'm going to take it by the dead of night and drop it in a large body of water where it will never bother anyone again!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
Head Gasket

The only thing different from stock is they sent me a steel Head Gasket. The original was this blue fiber stuff. I ordered a blue one tonight I will switch them out and see what happens.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #11
Do you mean..the cylinder base gasket. YES RTV.
the RC230 does not have a head gasket..
Yes that's the one I'm talking about. I never worked on one of these engines before. don't know what to call stuff. Thanks I have some RTV, Steve at DDM said they were made not to use anything on them. Just crank them down to 5Ft pounds.
 

·
Registered
Joined
·
2,466 Posts
I was just making SURE you and I were talking about the same engine.

I still use RTV on the gaskets.

where the block gasket meets the cylinder base gasket. it will leak there without RTV.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #13
Off to the shop

I took this engine all apart. Checked everything. Put it back together. Put the choke on 3 or 4 pulls and she pops, turned off choke. 3 or 4 pulls it fires up idles about 6 or 8 seconds quits will not fire again. JUNK
 

·
Registered
Joined
·
11 Posts
Discussion Starter #14
It RUNS!!

I think I was just flooding it all this time. Let it dry out over night, turned L screw out 1 & 1/2 turns instead of 2, started and ran like a champ. Thank You all for the Help and Support Mike
 
1 - 14 of 14 Posts
Top