Hobbyist Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
This is a 14 hp single cylinder motor. It is backfiring through both the carb and exhaust. I think i have checked all obvious things, checked and replaced fuel. Checked flywheel key, checked valves and cam timing good. still cant figure out why it wont start. I shut off fuel to carb and atempted to start w/ just starting fluid but same thing happens, engine cranks a bunch before backfire through carb or exhaust. also spark is good, I feel this is a timing issue as engine does not run fine on just starting fluid..

any help is appreciated!!!
 

·
Registered
Joined
·
2 Posts
FC420V Backfire

Same problem here with the FC420V backfiring through both the carb and exhaust. replaced carb gaskets and o-rings, and ignition module, no luck.

thanks for any ideas,

j.
 

·
Registered
Joined
·
2 Posts
FC420V Backfire

Same problem here with the FC420V backfiring through both the carb and exhaust. replaced carb gaskets and o-rings, and ignition module, no luck.

thanks for any ideas,

j.
 

·
Registered
Joined
·
173 Posts
could be carb is clogged or machine isn't getting fuel the way it should which means a clog in carb/gas line/gas filter if equiped. clean throughly and see what happens, jets included
 

·
Registered
Joined
·
6,116 Posts
Same problem here with the FC420V backfiring through both the carb and exhaust. replaced carb gaskets and o-rings, and ignition module, no luck.

thanks for any ideas,

j.
What is the spec number from your engine?

Have you checked the compression or done a leak down test?

Check the valve lash, valves that are adjusted too tight can cause this type of issue.
 
1 - 5 of 5 Posts
Top