Hobbyist Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
Snowmobile engine problem

I just recently got my snowmobile (1974-75 Arctic Cat Panther 440) running after about 5-6 years of it sitting out in the elements and not being used. It has not been running very smoothly. It will not idle and dies when I let go of the gas. Also I can not get it to move now. The track will not spin. It will start and I can rev it, etc... but the track will not spin. When I rev it the clutch spins but the track won't spin. Any help with this would be appreciated. Thanx in advance for any help. :)

Here are the specs:
1974-75 Arctic Cat
Panther 440

Engine:
Kawasaki
2 cylinder
Model #= TIC440S2A
Carburetor Model=WF1A
 

·
Registered
Joined
·
750 Posts
the clutch may be bad, or your not getting enough RPMs to engage it. is the engine runnign fine? and when was the last time you rode it? check carb tank gasket diaphram and clean if not get a rebuild kit on e bay
 

·
Registered
Joined
·
75 Posts
I have a similar sled. You need to take the carb off and clean it really good. I would replace all the fuel line back to the tank. Look in the tank, it may be rusty, no point in fixing the carb until you fix the rust in the carb, it will only clog again.

Are both clutches turning? Sounds like the chain is in the chaincase is broken???
 

·
Registered
Joined
·
750 Posts
tank.. if stored right shouldnt rust.. BUT it might if left outside with 1 year old gas mixed with water... thats a different story =P
 
1 - 4 of 4 Posts
Top