Hobbyist Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
I have a Bad Boy ZT mower with 2 hydrogear transaxles, the seal that is underneath the pump pulley is leaking on one of the pumps, and I have'nt been able to get the pully off, not even with a puller. Is this pulley threaded? If so how do you block the shaft?:confused:
 

·
Registered
Joined
·
333 Posts
I would say that either on the collar of the pulley or inside the "v"section of the pulley should be hex head set screws that need to be loosened. once that is done they should slide off with ease, if it does not come off with ease you may need to use a 3 jaw puller or bearing puller get them off. Does this pulley have a collar that is attached to the pulley with bolts? Some company's use this set up, if so you need to remove the bolts and move them to the threaded open holes on the collar and evenly tighten them until the pulley removes it self from the collar. Once that is done you can slide the collar and pulley off. Assembly is reverse of the above.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
It does not have a collar it is recessed in the center with a 3/4" nut, the tech at bad boy claims it pulls off, but I don't think so. I have not looked in the v portion for a set screw but thats a good idea! The only thing is I may have to remove the trasaxle to see in the groove. I did try a puller, and there is definitly something else holding it.
THANKS!
WT
 
1 - 3 of 3 Posts
Top