Hobbyist Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a relatively new Honda GX340 engine that ran flawlessly all last year. A week ago I cranked it and ran it several minutes with no problem. Yesterday I tried to crank it and it would smoke (white) heavily, run for about 10 seconds and quit running. An oil and gas mix would run out of the air intake of the carburator. I then noticed that when I unscrewed the plug where you put the oil, it was overfilled with an oil and gas mixture. Any suggestions??????

thanks
 

·
Registered
Joined
·
45 Posts
Do you shut off the fuel after each use? Have a unit that seeps gas into engine, resulting in the same condition you descripe. Have not pin pointed cause of seepage yet but shutting off fuel between uses has stopped smoke and dieing problem.
 

·
Registered
Joined
·
530 Posts
i havent heard much of this problem, but i think Homer may have your problem already caught. I have the same engine on a generator and havent had it happen yet. :confused:
 

·
Registered
Joined
·
13 Posts
Change the oil and make sure you shut off the fuel petcock between uses. If you still have the problem the carb needs to cleaned.
 

·
Registered
Joined
·
15 Posts
I agree with the change the oil and shut the fuel off after use. I would say the carb has varnished up and the seat is not shutting off.
 

·
Registered
Joined
·
13 Posts
Definately sounds like the float is not shutting off the fuel flow. Take out the float and shake it near your ear, if you here sloshing in it, replace along with a new needle and seat. Alternative way to check is to put the float in liquid and if it sinks, replace it.
 
1 - 10 of 10 Posts
Top