Hobbyist Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1 (Edited)
Hello everyone and merry christmas to those who celebrate it.
To everyone else happy holidays!!!
I have an MTD yardman with a b+s quantum 6 hp.
I have been fixing mowers for a couple of months for extra money.
but this mower is something else.It has good comp.,,,ignition new pull rope..
new oil sharpen + bal blade Etc...There was a govenor spring that was missing and so i looked on line at prices.Andfor eplod.view of carb.I figured out that
I needed a spring that is aprox.3"long and so I went down to the dealer down the street from me .He looked it up and said the part # was correct.
NOW THE problem.I rebuilt the carb and its getting fuel squirting when you push the primer.When you spray starter fluid it starts and stalls.It wont start with out spraying
The govenor spring is conected to the gov.arm with the linkage on it.
And the other end of the springconects to the throttle bracket .The problem is that when you connect the spring to the bracket it holds the throttle choke open
in the throat.When i go on line the veiw i get tells me there is only one spring.
And shows it in the position that I have it in.and if I disconnect the spring and stick a screwdriver in down to hold the choke closed to the idle position the mower still wont stay running HELP WOULD BE COOL.PLEASE
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
B+S wont run

hey guys,
Ive been cleaning carbs awhile i've had this walbro of a few times.
And there is nothing in it. I've cleaned the nut twice and the holes are beaut.
Model:123ko2
Type:0219-E1
Code:04062556
Govenor spring part#:699056
I flushed it out with brake cleaner and used a twist tie in all the hole even the
three just behind the choke butterfly.The bowl fills up.The primer peeps fuel.
the only other thing i can think of is the O-ring on the backside of carb @ the maniflod bracket But it looked pretty good and the carb is snugged up.
 

·
Registered
Joined
·
6,116 Posts
Hello everyone and merry christmas to those who celebrate it.
To everyone else happy holidays!!!
I have an MTD yardman with a b+s quantum 6 hp.
I have been fixing mowers for a couple of months for extra money.
but this mower is something else.It has good comp.,,,ignition new pull rope..
new oil sharpen + bal blade Etc...There was a govenor spring that was missing and so i looked on line at prices.Andfor eplod.view of carb.I figured out that
I needed a spring that is aprox.3"long and so I went down to the dealer down the street from me .He looked it up and said the part # was correct.
NOW THE problem.I rebuilt the carb and its getting fuel squirting when you push the primer.When you spray starter fluid it starts and stalls.It wont start with out spraying
The govenor spring is conected to the gov.arm with the linkage on it.
And the other end of the springconects to the throttle bracket .The problem is that when you connect the spring to the bracket it holds the throttle choke open
in the throat.When i go on line the veiw i get tells me there is only one spring.
And shows it in the position that I have it in.and if I disconnect the spring and stick a screwdriver in down to hold the choke closed to the idle position the mower still wont stay running HELP WOULD BE COOL.PLEASE
If you have a primer then there is NO choke on this carburetor. The governor spring is supposed to hold the throttle plate OPEN when the engine is not running. Once the engine starts, the governor should pull the throttle back to regulate the engine speed. If everything looks good in the carburetor, then you need to inspect the intake tube for possible air leak. Check for cracks and make sure it has a gasket and is tight where it mounts to the cylinder head.

Best of Luck....
 

·
Registered
Joined
·
668 Posts
Check the needle and seat in the carb. The seat is a type of rubber and will swell shut. While you have the carb off replace the o-ring for good measure. (they are inexpensive) Best of luck.
 

·
Registered
Joined
·
1,767 Posts
Since the carb and bowl nut are clean, check to make sure you haven't lost the "O" ring seal between the carb and intake, IPL # 617, part # 270344. Have a good one. Geo
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
thanks guys ive bee thinking that the O-ring might be the culprit i'm going to pull it apart AGAIN and see this motor confused me because it has a throttle cable and if you hook it up it is usless.I thought when i saw the single govenor spring that something looked amiss.I'll let you know.Steven
 

·
Registered
Joined
·
28 Posts
Discussion Starter #9
Hey guys ,
Just thought you would like to know.
I took the carb off again and the intake braket that the carb bolts up to was slightly bent.Just as we figured the O-ring was leaking air.And the throttle situation is straight.I primed it 4 x and pulled it twice fired right up .I just need to lower the idle a little bit and I think she is ready for sale.Well actually right after I adjust the cables.Thank you all. STEVEN
 
1 - 9 of 9 Posts
Top