Hobbyist Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, this is my first time working on anything related to engines, so i really don't know much at all. I bought a few leaf blowers from a guy, all of them need work so i came here for help.

I looked into genereal maintainence of a leafblower and have done a few things, (hopefully i didn't mess up anything)

-took off muffler and soaked it in hot water with soap(it was really dirty inside)
I also soaked the carb, i disassembled it first, but i read i should be using carb cleaner and that water & soap wont do much.

thats pretty much it. Also, this is something i have been really wondering haha.. how come when i remove the spark plug and pull the string the motor sounds almost as if it is gonna start, but as soon as i put the spark plug back in and pull, it doesn't sound like it's gonna run at all(barley any engine noise). Just looking for tips on how to start it, maybe something i should try doing. I think i may need to get a carb kit.

P.s the air filter is missing, but i should be able to start it without at it correct? If i can get it to run im going to buy one of course. Thanks to all who wil help
 

·
Registered
Joined
·
1,767 Posts
To begin, before you invest any money.
Remove the spark plug, hold your finger over the hole and pull the starter rope, if it blows your finger away continue, if not, try another. Remove the muffler, look in the exhaust port while turning the engine, if you see deep scores(scratches), go on the the next one. Invest in a compression tester $15 at HF, a 2-cycle needs about 90lb to run. Have a good one. Geo
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hi Geo, thanks for the reply.

I did what you said, and yes it blew my finger back. Also i took the exhaust off and looked in side while slowly pulling the rope. I seen a metal thing(again i don't know mch at all about engines haha) moving up and down, it was smooth. i did not see any scratches on it.

I forgot to mention that before i started working on it, i tried to start it like you would any normal 2 cycle machine. The engine would start on full choke for a bout 1-2 seconds, some smoke would come out of the exhaust and then it would stop. What would be my next step seeing as the motor is still good?
 
1 - 3 of 3 Posts
Top