Hobbyist Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have posted earlier messages about a B&S 18 HP that I have.
It is the twin II enigine.

It wont start, pops a little. It does have spark. I think the compression is okay. My compression guage has no reading but the cylinders are fine and the cylinder walls are like new. In fact it only has a few hours on it.

I believe a connectiing rod went. It had been repaired once before.but never ran again. It was suggested that I tear it down and check the valve timing. I believe the timing marks were aligned. When aligning the marks does it matter what position and the cylinders are in?

What else should I look for while it is apart????
Should I take out the pistons and check the rings? It seems like it would be a waste of time. As I mentioned above the piston walls are fine and the pistons are good.

Could it have been the an improperly installed governer?
 

·
Registered
Joined
·
3,241 Posts
i would check the rings they might have the gaps lined up causing no compression because i had one of those same engines but with the iron liner that had that.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I will check it out.

Does the gear for the governer have any special orientation?
I know on the gears for the crankshaft and camshaft need to line up.
 

·
Registered
Joined
·
3,241 Posts
yes it should, make a small mark on it to give you a point on where to put it back if you have allready taken it off i wouldn't really know where to put it back to because i only had just one of those engines and i always marked everything for orientation. i have long since sold that motor for a good $250 because the body rusted apart. the governor should be adjustable so i guess if you have allready tooken it off, adjust it until it runs good kind of like a go-cart. my 18 horse had the governor on front and was adjustable by loosening the screw and moving it to what you want. now i do know that compression does have an affect on plug life so if there is no reading on the gauge do check it.................... when you do get it running right never use champion plugs use an autolite or something else. never buy the b&s plugs neither there champions and they suck.
 
1 - 4 of 4 Posts
Top