Hobbyist Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
Help!:( A friend asked me to take a look at his HC150....does not want to idle right or run smooth...Dumped gas,cleaned carb(dis assembled),even put in carb kit.....It will crank up on choke and run on choke...start to ease off on the choke,and then it starts to rev up(the whole time NO throttle pulled)....and then it sounds like it just runs out of gas!:confused:About 1 1/2 years old.....I Give Up!:confused::confused::confused::confused:
 

·
Registered
Joined
·
668 Posts
While the trimmer is running spray carb cleaner around the mating surfaces at the carb. If engine tempo changes you have an air leak. Also, did you check your fuel filter and the lines going to the carb. There might be a pin hole in the fuel line.

Good luck.
 

·
Registered
Joined
·
810 Posts
I worked on an Echo hedge trimmer, I believe it was the same #. Cleaned carb and put in new parts. Still would not run right. The place I got the parts from said they usually replace the carb rather than putting in new parts, due to the non-replaceable check valves that I probably ruined when cleaning. How did you clean the carb? I ordered a new carb and it ran perfect. I believe the carb was around $30.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #7
Still no result...It runs the same as before cleaning...tried the spray carb cleaner around carb base,no change.It just must need a new carb.:(Where is the best place to get one?:confused:
 

·
Registered
Joined
·
649 Posts
What model carb do you have on it? The HC150 should have the Zama, there is a black plug which blocks access to the adjustment screw, I have the echo tool at work but normally you can remove the plug with a small wood screw.
 
1 - 9 of 9 Posts
Top