Hobbyist Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
I have this Craftsman 18.0 HP 42" mower. I had this problem with it running great and then it would start to miss then almost cut out but the start run the the same until it stop . I checked the gas cap and the hole is clear. I then checked the spark plug wire and pulled it off and the cap had broken loose. Fix that and the same thing happen. Bought a new armature. and the same thing happen. Bought a new plug, same thing. This happens after the engine get hot. This is a B&S engine model # 31H777 Type # 0297E1 Code # 040121ZE1

Any hints on what I should do next? George
 

·
Registered
Joined
·
46 Posts
Hi,

from your post, can I assume that the motor is starting to miss when the motor is warm?

1/ Ensure that fuel lines are away from any sources of heat.

2/ Ensure cooling fins are clean so the motor does not overheat.

3/ Put an inline spark tester to see what happens to the spark when the motor dies. This can give us some clues. Maybe, the spark cable has an intermittent break in it?

4/ Check to ensure that the cylinder head bolts are not loose.

5/ Check that your fuel lines are not blocked.

6/ Ensure you have fresh gasoline. Stale gasoline is bad news. Water mixed with your gasoline is also bad news.

7/ Check that you have enough oil and that it is not contaminated with gasoline. Also, ensure the oil is not due for an oil change.

8/ Check that the air filter is not blocked.

Has your motor blown any smoke?
If so, what color (colour) ?

9/ Check that the muffler is not blocked


If the above don't rectify your problem, you may want to check that the carby is not blocked.

When the motor stops, can you restart it? Or do you have to wait a while?

Let us know how it goes.

Al Bunzel
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #3 ·
This engine has been will cleaned and maintain. There is no grass around the fins, oi and fresh gas at every mowing. The spark plug and spark plug wire is brand new. The engine starts right up when cold. I will run it for 10 to 15 mins. and then it starts to miss and cut out. When it stops completely it will start right up but misses and cuts out. When it is running and missing I tap the fuel solenoid and the engine clears right up, I then can make a few passes and then it will do the same thing. Could it be the fuel solenoid
 

·
Registered
Joined
·
111 Posts
It sounds like the fuel selenoid if you tap it and it clears up then thats where I would look at replacing. I have had a couple on koler motors do this.
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #5 ·
Well I got this mower running in great now. Like I said when I tapped the fuel solenoid it would clear up. So I ordered a new one, plus a air filter, oil filter, and a gas line shut off. Installed everything and it runs great. While I was waiting for the parts I did a complete maintence on the mower. I also put a new cable clutch on. Got that at sears which was cheaper then anyone online. Thanks for the help. George
 
1 - 5 of 5 Posts
Top