Hobbyist Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a craftmans eager mower model# 917.377810 it is about 4 years old. I was cutting grass and it was running fine, I stopped the mower to move something, when I tried to start it again it would not fire. I tried to start it the next day, it did start, I let it run for about 30 seconds and then shut it down. I tried to restart it and it would not fire. I let it sit over night, I tried to start it again, it did start, I let it run 5 to 10 seconds shut it down and tried to start it and once again it would not fire. Does anyone have any ideas on what could be wrong? Carl
 

·
Registered
Joined
·
3,241 Posts
try a new plug and not a champion plug, try that first. as for plugs use an autolite small engine plug.............. and also clean the combustion chamber by hand and clean the carb with carb cleaner while its running it will help with perfomance to keep it clean
 

·
Registered
Joined
·
269 Posts
My guess is that your fuel inlet valve is sticking or partially restricted due to some crud or you have a restriction in the line leading to it. Disassemble, clean and blow out with compressed air.
 

·
Super Moderator
Joined
·
767 Posts
My father in laws mower Craftsman, unk numbers, does the same thing. It starts cold and then fails to start when it's warm or hot. 15 or 25 minutes later, starts right up. I changed spark plug, fuel lines, muffler and anything else I could think of. None of it worked. I spent hours researching on the internet. All I found was no one had a solution. It was some type of engine quirk.

I ended up putting a piece of wire on the safety bar and keeping it on the handle so the mower wouldn't shut off if you moved something and had to let go of the handle.

Good luck.
 
1 - 4 of 4 Posts
Top