Hobbyist Forums banner

61 - 71 of 71 Posts

·
Registered
Joined
·
1 Posts
Club car not getting fire

Hi I have a 2000 club cart turf 2 with kawasaki fe350 engine. It's not getting fire put new plug still nothing. Stumped any ideas
 

·
Registered
Joined
·
1 Posts
07 Club Car

Hello everyone, I'm new to the sight and need some help.
07 Club Car gas engine. Here's the problem, it runs good until hot and then dies, after I let it set for a few minutes it runs good until it gets hot again and just keeps on doing it. I've been through the whole fuel system. Charging system checks good. Any help would be greatly appreciated.
 

·
Registered
Joined
·
1,349 Posts
Hello everyone, I'm new to the sight and need some help.
07 Club Car gas engine. Here's the problem, it runs good until hot and then dies, after I let it set for a few minutes it runs good until it gets hot again and just keeps on doing it. I've been through the whole fuel system. Charging system checks good. Any help would be greatly appreciated.
Please start a new thread.
 

·
Registered
Joined
·
5 Posts
Make sure you have fresh gasoline too. I've had some units vapor lock etc. Not sure if this is the case but you'd be surprised the number of times that it turns out to be something simple.
 

·
Registered
Joined
·
1 Posts
I have a 1987 Ezgo 2 cycle golf cart that ran. Sat for a hour and it sounds like the starter will not engage. Have fire and lights work. Has the starter/generator gone out?
 

·
Registered
Joined
·
1,349 Posts
Please start a new thread. Please start a new thread. Please start a new thread. Please start a new thread. Please start a new thread. Please start a new thread. Please start a new thread.
 

·
Registered
Joined
·
1,349 Posts
Really, 5 pages on an old thread and people keep chiming in. We want to answer you, but really, really, please start a new thread to keep things sane.
 

·
Registered
Joined
·
1 Posts
1999 club car

Have a problem with it starting, all new micro switches , starter checked by shop it is good , step on peddle it clicks get full voltage to starter but only .80 volts to yellow wire on starter from regulater
 

·
Registered
Joined
·
2 Posts
Last message posted in 2009?
Maybe its a dead thread but I joined to ask anyways.

Im in the process of looking to buy a used club cart for golfing. I recently spoke with a gentleman who has two carts a 1993 and a 1994. Both however he says have "pinging" noise. He didnt have the keys when I seen the carts, both garaged whole life.

QUESTION: What can cause the "pinging"? Is this something to avoid?

Ive been told that any of these are possible causes.........Value Train, Rod Bearing, Piston, Loose rockers need adjusting.

Thanks for any replies
 
61 - 71 of 71 Posts
Top