Hobbyist Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
369 Posts
Discussion Starter #1
I run a nitro truck and I have installed a airtronics 94357 steering servo. When servo trys to center itself it starts to chatter real bad side to side, sometimes real back, sometimes not too bad. I pulled the servo out and checked it with several other radio systems that I have and still the same thing. Is there a simple fix or can I send it in somewhere to have it fixed... I really like this servo but cant drive it with the chatter in it. ANY help is better than where I am now.. :confused: Thanks and have a great day... Patrick
 

·
Registered
Joined
·
369 Posts
Discussion Starter #3
Thanks fordplay but dont think glitching is the problem. I use spektrum system and never had problem before, besides I took it all the way out of truck and bench tested it with several different radio systems, spek, am, fm, and it still does the same thing.... Thanks for the reply... Patrick
 

·
Registered
Joined
·
369 Posts
Discussion Starter #6
No it is not a new servo, used it a couple months ago and never had a problem, went to run it yesterday and kazam, not working right.... Thanks for the replys though.... Patrick
 

·
Registered
Joined
·
3,927 Posts
You can send it in to Airtronics.
 

·
Registered
Joined
·
2,198 Posts
Where is your D/R or Dual Rate set? Sometimes when you have the D/R set very high it will cause the servo to chatter like that. Back it off and it may stop or clear that problem. The other thing to check whether the servo's not returning to a resting state or dead center with no load on it, it can chatter like that too.

PD2:thumbsup:
 
1 - 13 of 13 Posts
Top