Hobbyist Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hey ht. I have a go kart that has a 3.5 hp power sport techumseh. We just replaced the clutched cause we thought that was the problem,(it wasnt't).

The problem:

when start it sounds like the clutch rubs then it just stops

we took out the spark plug and dipped it in gas and the go kart ran for about 5sedc but sounded normal.


ANy help is greatly appreciated.

~kid
 

·
Registered
Joined
·
98 Posts
start by making sure that gas is getting to carb. maybe pull the bowl off the carb and see if any water or dirt specks are in the bowl. make sure the gas in the tank is clean and fresh and doesnt have any water in it or dirt. if so then get all that cleaned up put some good gas in it and let us know.
 

·
Registered
Joined
·
46 Posts
start by making sure that gas is getting to carb. maybe pull the bowl off the carb and see if any water or dirt specks are in the bowl. make sure the gas in the tank is clean and fresh and doesnt have any water in it or dirt. if so then get all that cleaned up put some good gas in it and let us know.
I agree with hd4ou. In addition, I would check that the tank cap is venting properly.
Also, whilst the bowl is off the carb, check that the float is not sticky.
Also, check that the pipe from the tank is not blocked.

Check that there are no leaks at the intake manifold and that the carby primer button is not broken.

Kind Regards
AlBunzel
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top