Hobbyist Forums banner

21 - 40 of 54 Posts

·
Starship Class
Joined
·
11,676 Posts
No. I used the kit part. I did however, use an aftermarket "Bridge" That is much closer to the filming model. In all honesty, the Impulse engines I could live with...That bridge however...
Gotcha! You know, I really thought the impulse engines (which the model company admitted just plain giving up on trying to get the Chinese to get correct) would be the big thing that everyone wanted to get an aftermarket part for due to its shape being quite a bit off. As things turned out, hardly anyone cares or even notices. :surprise:

Special effects model refit Enterprise impulse engines off

Special effects model refit Enterprise impulse engines firing

R2 refit Enterprise impulse engines
 

·
Registered
Joined
·
4,186 Posts
Discussion Starter #36
Gotcha! You know, I really thought the impulse engines (which the model company admitted just plain giving up on trying to get the Chinese to get correct) would be the big thing that everyone wanted to get an aftermarket part for due to its shape being quite a bit off. As things turned out, hardly anyone cares or even notices. :surprise:

Special effects model refit Enterprise impulse engines off

Special effects model refit Enterprise impulse engines firing

R2 refit Enterprise impulse engines
You have to pick and choose your battles...There are a number of slightly off and incorrect things going on around here. But it's just a model and the builder can decide how far to go with it.I actually may correct the area at a later date. Currently,however, I simply don't have the time.
 

·
Starship Class
Joined
·
11,676 Posts
You have to pick and choose your battles...There are a number of slightly off and incorrect things going on around here. But it's just a model and the builder can decide how far to go with it.I actually may correct the area at a later date. Currently,however, I simply don't have the time.
Agree on all points :thumbsup:
 

·
Registered
Joined
·
430 Posts
Mark,

The build looks real good! You stated you used the Orbital Drydocks masking set. Have you ever used the TrekModeler masking set? It looks very detailed, but very expensive as well. Keep up the outstanding work.

Thanks

Phillip1
 

·
Registered
Joined
·
4,186 Posts
Discussion Starter #39
Mark,

The build looks real good! You stated you used the Orbital Drydocks masking set. Have you ever used the TrekModeler masking set? It looks very detailed, but very expensive as well. Keep up the outstanding work.

Thanks

Phillip1
Many thanks my friend! No I haven't used the TREKMODELER masking set...Perhaps in the future, I still have three more of these to do!!!:crying:
 
21 - 40 of 54 Posts
Top