Hobbyist Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
633 Posts
Discussion Starter #1
Today I went a local hobby shop in Silverdale WA and bought 3 kits to do. Revell Germany real space Apollo 11 CM and Lander 1/100 Scale and Polar Lights 1/1000 Refit Now I seem to remember another member here recently completed his refit project despite problems with the azteck decals But i am wondering If he or any one here lit up theirs now myself installed LED's in the 1/1000 TOS Enterprise, The NX-01 Enterprise and the Klingon Cruiser with little to few problems. While I was test fitting this little darling today I realized that the wireing needs to be different than the previous projects but I think even using 3mm LED's is going to be a bit snug so, I was wondering If anyone else has done this kit and if they lite it up and what did you use.

AZbuilder
John Davis

Let Your Imagination Soar
 

·
Registered
Joined
·
2,255 Posts
You might also consider the surface mount LEDs. Your hand has to be super steady for soldering (mine shake too much!), but they are on the order of 1mm square.

BTW, I'm in Tucson. Where are you? Could be fun to meet up with a fellow modeler! :)
 

·
Registered
Joined
·
633 Posts
Discussion Starter #3
Continueing My Refit Build

To answer Chronjrs question, I no longer reside in Tucson, AZ I have relocated to Port Orchard WA since 2008. So anyway I have decided not to attempt to light this project as using 3mm LEDs were impractable due to their size and 1mm Surface Mount (SMD) are to small to solder the leads as my hands are to shaky to do the job. so I completed 4 sub-assemblies 2 nacelles, engineering hull, and Primary Hull and painted a white pearlesent color and sealed with Future for my gloss coat. And now I am ready to apply my decals. I anticipate several nights work based upon how long it took Cylon75 to do his decaling.

John Davis
AZbuilder

Let Your Imagination Soar
 
1 - 3 of 3 Posts
Top