Poulan 31cc PB300 gas trimmer, only runs with choke on. - HobbyTalk
  
HobbyTalk Forum for Diecast Collectors, Modelers, Slot Cars, & Radio Control
Home Forums Photo Album RC TrackFinder Catalog Donation/HobbyTalk Supporter

Welcome to the HobbyTalk forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, view attachments, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us. Forgotten your password? Click here!

NOTE: Once you register and are logged in this welcome section will no longer be visible.

Go Back   HobbyTalk > Small Engine Repair > Small Engine Repair 2-Cycle
Register Classifieds Help/TOS Members List Calendar Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 09-07-2007, 02:57 AM
revalation22_5 revalation22_5 is offline
Member

My Photos
 
Join Date: Sep 2007
Posts: 3
Poulan 31cc PB300 gas trimmer, only runs with choke on.

First off I am amazed at all the imformation on this site, You guys do a great job.

now for my problem. What I thought was gonna be a general carb cleaning for my father in law has me really scratching my head. He asked me to look at his Poulan Pro PB300 trimmer. Said it would not idle and dies when you try to give it gas. I figured it would be simple and I would just have to clean the carb and maybe replace the diaphgram. so first i cleaned the carb but that did not help so I went to order a carb kit and was told I would have to buy the whole carb no big deal. so i bought the carb and installed it. but it still does not want to run with the coke off. I have replaced
The Fuel Filter
The Fuel Cap (in case it was not venting)
The Carb
The Primer bulb.
I
It will start with the choke on and run and rev up, but when the choke is off it will idle for a few seconds and when you try to give it fuel it will die.

It does not look like the high and low circuts are adjustable because they have a odd cone shaped thing where the screws normally are.

I have also forgot how to route the lines.

Any help would greatly be apprecaited.






thanks
Reply With Quote
  #2  
Old 09-07-2007, 01:48 PM
geogrubb geogrubb is offline
Elder Statesman

My Photos
 
Join Date: Jul 2006
Location: Missouri
Posts: 1,608
Even though you now have a new carb it can have the same problem as the old one, the carbs are manufactured and the set on the shelf for extended periods of time and the diaphgram and gaskets dry out. Anyway, I think your trimmer has a Walbro WT628 carb and kits are available, as of right now www.oscar-wilson.com has Diaphgram kit D20-WAT for $4.17 with 33 in stock and Repair kit K20-WAT for $8.23 with 48 in stock. If that is not the carb or proper number post back with what is on the trimmer or the new one you purchased and we will try to chase it down. I have seen posts on this forum to make an adjustment tool is drill a 9/64(I think that is the size)hole in the end of a piece of 1/4" dowel stock then tap it over the screws to create a tool for adjustments or removal. For the fuel lines I suggest going to your local Wal-Mart and check the lines on a trimmer, they sell Poulan, that is the surest way to get the lines correct. Have a good one Geo
Reply With Quote
  #3  
Old 09-07-2007, 07:42 PM
geogrubb geogrubb is offline
Elder Statesman

My Photos
 
Join Date: Jul 2006
Location: Missouri
Posts: 1,608
After further checking the 31cc engine may have a Zama Carb and according to the parts list there is no repair kit available for the C1U-W32 carb. However, the C1U-W32 uses repair kit RB-142 and diaphgram/gasket kit GND-78. You can order either at the following.

www.hhlce.com/shop/zama/zama-Index.htm

The RB-142 is $8.95 and the GND-78 is $5.95
Have a good one. Geo

Last edited by geogrubb; 09-07-2007 at 08:05 PM..
Reply With Quote
  #4  
Old 09-07-2007, 07:47 PM
revalation22_5 revalation22_5 is offline
Member

My Photos
 
Join Date: Sep 2007
Posts: 3
you are correct it is a WT628 carb. I may order a kit for it just to be sure, I really want to get this thing going. Is there anything else it could be?
Reply With Quote
  #5  
Old 09-07-2007, 08:17 PM
geogrubb geogrubb is offline
Elder Statesman

My Photos
 
Join Date: Jul 2006
Location: Missouri
Posts: 1,608
You shouldn't need the whole kit just the diaphgram/gasket kit. Unless you have an air leak somewhere which will create the same symptoms. While you have it running you might spray some carb cleaner along any mateing surfaces(engine housing,carb to crankcase, etc.) to see if the engine tempo changes which would indicate a leak. Have a good one. Geo
Reply With Quote
  #6  
Old 11-09-2007, 06:25 PM
hec1943 hec1943 is offline
New Member

My Photos
 
Join Date: Nov 2007
Posts: 1
Exhaust Port Clogged

I have a Poulan leaf blower and I have found that the exhaust port will begin to build up a carbon deposit after many hours of use. This causes the engine to run slow and somewhat rough. Take the exhaust muffler off and check the port for carbon build-up.

HEC
Reply With Quote
  #7  
Old 11-09-2007, 07:32 PM
30yearTech's Avatar
30yearTech 30yearTech is offline
HobbyTalk Supporter

My Photos
 
Join Date: Sep 2006
Location: Central Texas
Posts: 5,742
....

Last edited by 30yearTech; 11-10-2007 at 10:47 AM..
Reply With Quote
  #8  
Old 11-10-2007, 01:29 AM
geogrubb geogrubb is offline
Elder Statesman

My Photos
 
Join Date: Jul 2006
Location: Missouri
Posts: 1,608
Did anyone realize this post is 2 months old without a response from the original poster. Have a good one. Geo
Reply With Quote
  #9  
Old 11-10-2007, 10:45 AM
30yearTech's Avatar
30yearTech 30yearTech is offline
HobbyTalk Supporter

My Photos
 
Join Date: Sep 2006
Location: Central Texas
Posts: 5,742
Quote:
Originally Posted by geogrubb
Did anyone realize this post is 2 months old without a response from the original poster. Have a good one. Geo
Ha ha...Apparently not, I know I never paid any attention to the date.

Have a great one

Last edited by 30yearTech; 11-10-2007 at 10:53 AM..
Reply With Quote
  #10  
Old 06-14-2009, 01:08 AM
niteman9 niteman9 is offline
Member

My Photos
 
Join Date: Jun 2009
Posts: 6
I know this thread is over a year old but I am having the same problem. I need to know how to connect the fuel lines. So could someone in the know take his diagram and show how to connect the fuel lines. I am about to run over this thing with my truck.
Reply With Quote
  #11  
Old 06-14-2009, 01:31 AM
niteman9 niteman9 is offline
Member

My Photos
 
Join Date: Jun 2009
Posts: 6
Here is the way I have it now and cant seem to get it to start.
Attached Images
File Type: jpg Poulan Fuel routing2.jpg (14.5 KB, 68 views)
Reply With Quote
  #12  
Old 06-14-2009, 03:06 PM
Lawnmowertech Lawnmowertech is offline
Member

My Photos
 
Join Date: Nov 2008
Location: Newport, North Carolina
Posts: 347
niteman have you checked the filter ? to make sure it is ok even the purge pump bulb to see if it has a crack in it or air leak ?

the lines look ok cause you have the fuel coming into the diagphram end of the carb going to the bulb and going back into the tank you can try switching it to see if it works but if it dont work then i would take and look at the other possible causes

ignition system

primer system

etc.


check the muffler also to see if it is plugged up

hope this helps

calvin
Reply With Quote
  #13  
Old 06-14-2009, 03:24 PM
niteman9 niteman9 is offline
Member

My Photos
 
Join Date: Jun 2009
Posts: 6
Thank for the reply. The fuel filter, tank, carb, and fuel lines are all new. The primer bulb does not have any cracks. If I cover the shorter fitting and press the bulb does not release until you remove your finger. It seams like this fitting on the bulb is pushing gas when depressed and pulling when released. Is this correct? How do I check the bulb an make sure it is working correctly?

Also with the fuel lines in this position gas runs out the air cleaner side when primer is pushed.

Last edited by niteman9; 06-14-2009 at 04:53 PM..
Reply With Quote
  #14  
Old 06-14-2009, 08:47 PM
Lawnmowertech Lawnmowertech is offline
Member

My Photos
 
Join Date: Nov 2008
Location: Newport, North Carolina
Posts: 347
Quote:
Originally Posted by niteman9 View Post
Thank for the reply. The fuel filter, tank, carb, and fuel lines are all new. The primer bulb does not have any cracks. If I cover the shorter fitting and press the bulb does not release until you remove your finger. It seams like this fitting on the bulb is pushing gas when depressed and pulling when released. Is this correct? How do I check the bulb an make sure it is working correctly?

Also with the fuel lines in this position gas runs out the air cleaner side when primer is pushed.
sounds like its working properly

switch the lines around on the carb see what happens
Reply With Quote
  #15  
Old 06-14-2009, 11:09 PM
niteman9 niteman9 is offline
Member

My Photos
 
Join Date: Jun 2009
Posts: 6
I switched the lines on the carb and was able to get it started. Put the string trimmer attachment on it and used it for a while. When I was done I noticed it was on 1/2 choke. When I opened the choke it would die. I pulled it apart again and swapped the lines back on the carb. Couldn't get it started. Swapped them back and got it started again. This time it would run with the choke open. So well see how it works. Thanks for the help.
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Featured Sponsor
You Can Sponsor
A HobbyTalk Forum


HobbyTalk® Sponsors
Diecast
CScollectibles
Collectables Corner
DieCast Alley
Global Diecast Direct
Milezone
Mini-Motors Inc
Scoomer
The Toy Peddler
Toy Car Aution
Models
MegaHobby
Modeler’s Brand
ParaGrafix Modeling Systems
Radio Control
BeachRC.com
B-Fast RC
Dirt Cheap RC
Discount RC Tires
Irrgang Racing Service
Lefthander RC
MaxAmps.com
RCTV Live
SMC Racing
Speedzone
Thunder Racing
Tekin
Trend Times
TQ Racing
Windtunnel Racing
Slot Cars
AFX Racing
Scoomer
Slot Magazine
Sponsored Events

Become a
HobbyTalk® Supporter

Advertise on HobbyTalk®



Powered by vBulletin®
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All times are GMT -4. The time now is 05:32 PM.
HobbyTalk® is a Registered Trademark of HobbyTalk Ltd.
All other logos and trademarks on this site are property of their respective owner.
Copyright (c) 1997-2012 HobbyTalk Ltd. No use without permission.
Advertising positioning by Digital Point