Vacuum motor brush replacement - HobbyTalk
 
LinkBack Thread Tools Search this Thread
post #1 of 3 (permalink) Old 11-06-2011, 07:26 PM Thread Starter
New Member
 
Join Date: Nov 2011
Location: San Jose
Posts: 1
Vacuum motor brush replacement

I have replaced vacuum motor brushes before, but the last install resulted
in excess brush arcing. Is the armature at fault?
madselecrrp is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-06-2011, 07:51 PM
HobbyTalk Pro
 
chuck_thehammer's Avatar
 
Join Date: Oct 2007
Location: How do I escape from Ohio
Posts: 2,465
as long as the timming has not been changed...brush plate installed correctly..then YES>>>armature most likely bad.
chuck_thehammer is offline  
post #3 of 3 (permalink) Old 11-13-2011, 08:15 AM
Member
 
GhostKnight's Avatar
 
Join Date: Nov 2009
Location: Vienna, Austria, Europe
Posts: 23
Are you sure you have the right brushes? if they are too soft, the increased abrasion results in a shower of sparks (seen it often enough, when I put the wrong brushes into motors...)

greets

Tom
GhostKnight is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the HobbyTalk forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome